Support Forum

Support Forum » XPAND YOUniversal Electronic 3D Eyewear » Problem with 2.0.1 firmware - Panasonic AE-8000U projector

XPAND YOUniversal Electronic 3D Eyewear

Problem with 2.0.1 firmware - Panasonic AE-8000U projector

XPAND - World Leading Provider of 3D Solutions